Menu

Excel - Fonctions SI, ET, OU, NON

Avril 2018

L'utilisation des la fonction SI, de la fonction "ET", de la fonction "OU" et enfin de la fonction "NON" est une question récurrente que se posent tôt ou tard la plupart des utilisateurs d'Excel lorsque l'on crée des formules. Cette fiche décrit en pratique comment utiliser ces fonctions.


Afin de tester les fonctions présentées ci-dessous, vous pouvez le fichier de démonstration des fonction SI,ET,OU,NON d'Excel

Fonction SI

Fonction SI isolée

Si la note en A1 est supérieure ou égale à 19, alors afficher 20, sinon afficher A1
se traduit par la formule
=SI(A1>=19;20;A1)
Si la donnée en A1 est "Remise", alors retrancher 10%, sinon conserver A1
se traduit par la formule
=A1*SI(A1="Remise";1-10%;1)

Fonctions SI imbriquées

Si la note en A1 est supérieure à 12, alors afficher "continuez, " ; si A1>18, alors ajouter "c'est très bien", sinon afficher "satisfaisant". Mais si A1<=12, alors afficher "à améliorer"
se traduit par la formule
=SI(A1>12;"continuez, " & SI(A1>18;"c'est très bien";"satisfaisant");"à améliorer")
ou par la formule
=SI(A1<12;"à améliorer";SI(A1<18;"continuez, satisfaisant";"continuez, c'est très bien"))
Si la note en A1 est inférieure à 4, alors afficher "nul" ; si A1 compris entre 4 et 8, alors afficher "moyen" ; si A1 compris entre 8 et 12, alors afficher "moyen" ; si A1 compris entre 12 et 16, alors afficher "bien" ; sinon afficher "très bien"
se traduit par la formule
=SI(A1<4;"nul";SI(A1<8;"insuffisant";SI(A1<12;"moyen";SI(A1<16;"bien";"très bien"))))

Fonction ET

Afficher "Madame la comtesse !" si toutes ces conditions sont réalisées : A2 (sexe)=femme, B2 (statut)=mariée, C2 (époux)=comte et D2 (pointage)=présent ; sinon afficher "Bonjour"
se traduit par la formule
=SI(ET(A2="femme";B2="mariée"; C2="comte"; D2="présent"); "Madame la comtesse !"; "Bonjour")

Fonction OU

Afficher "Pilote" si A3 contient l'une des données suivantes : avion, formule 1, moto ; afficher "Conducteur" si A3 contient car ou travaux ; sinon afficher "?"
se traduit par la formule
=SI(OU(A3="avion";A3="formule 1"; A3="moto");"Pilote"; SI(OU(A3="car";A3="travaux");"Conducteur";"?"))

Fonction NON

La formule =SI(ENT(A3)=A3;"entier";"décimal")
peut aussi s'écrire
=SI(NON(ENT(A3)=A3);"décimal";"entier")
tout comme
=SI(A4<>"français";"étranger";"européen")
est équivalent à
=SI(NON(A4="français");"étranger";"européen")

Combinaisons

Les fonctions ET, OU, NON s'utilisent le plus souvent associées avec la fonction SI.
Tout l'intérêt (et le plaisir), pour celui qui utilise un tableur, est de définir une "table de vérité" et de dessiner un organigramme représentant l'algorithme du problème à résoudre, en combinant les 4 fonctions, et en veillant à respecter les parenthèses et les points-virgules pour que la formule fonctionne.
Il faut systématiquement tester une telle formule, en essayant tous les cas de figure et les valeurs limites des variables.

Observations

Il est évidemment souhaitable de compléter et d'aménager la présente fiche ; aussi toutes les contributions, suggestions et éventuelles corrections sont les très bienvenues.

à consulter également

A voir également


Article original publié par Raymond PENTIER. Traduit par ChristinaCCM.
Ce document intitulé «  Excel - Fonctions SI, ET, OU, NON  » issu de CommentCaMarche (https://www.commentcamarche.net/) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.
Excel [toutes versions] - Recopier une formule simple
L'outil "Appareil photo" sous Excel